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1. Introduction. 
Welcome to Power Data! Power Data is an easy-to-use and high performance database management 
system (DBMS) for the Nokia 9210/9290 Communicator. Power Data allows you to capture, store and 
retrieve information about similar items. 
 
Power Data offers you a wide range of powerful tools for managing databases like finding, sorting, and 
filtering records. It allows you to have multiple tables in a single database. Power Data supports import 
from and export to CSV and dBase (DBF) files. 
 
You can download the latest version of Power Data from http://www.epocware.com. 

2. Key concepts. 

2.1. Database. 
A Database is a file that contains structured information that's related to a particular subject or purpose, 
such as tracking customer orders or maintaining a music collection. It may contain one or more Tables. 
 

 
 

 

2.2. Tables. 
A Table is a collection of data about a specific topic, such as products or orders. Tables organize data into 
columns (called Fields) and rows (called Records). 
 

http://www.epocware.com/
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2.3 Records and Fields. 
A Record is a collection of data arranged in one or more Fields. Each record describes some unique “real 
word” entity such as person, product or order.  
 

 
 
Each Field represents some aspect or attribute of the entity such as name, address, or date of birth of a 
person. The definition of a field includes the name of the field and the type of data to be recorded. 
 
Power Data supports wide range of field types, including text strings, numbers (integers), yes/no 
(Boolean), floating point (currency) and date fields. 

3. Tutorial. 
The best way to learn a program is to create something in it. This chapter will take you through the 
process of making a database to store a mailing list data. 

3.1. Creating a database. 
To create a new database, select the New database command form the File menu. The New database 
dialog will appear, where you can choose the name and the folder for the database file. 
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Then you will be asked if you want to password protect the new database. 
 

 
 
If you choose to set the password, then you will be prompted to enter it. 
 

 
 
Note 1: You will be able to change the password later by selecting the Change password command from 
the File > More menu. 
 
Note 2: If you choose not to set a password, then you won’t be able to set it later. 
 
Now the database is created. There are no tables in it. The next step is adding a table. 
 



Power Data User Guide 

© Copyright 2002 Epocware, Paragon GmbH 7

 

3.2. Adding tables to a database. 
To add a new table to a database, press the New table button. Enter the name for the new table: 
 

 
 
Once you entered the name, the Templates dialog will appear, where you can choose a template for the 
new table. If you don’t want to use the templates, select the Other (blank) item. 
 

 
 
We choose the Mailing List template for our tutorial. Then the process of defining the fields within the 
table begins. 
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In the Table fields dialog you can see a list of predefined fields with their types. To remove a field, select 
it in the list and press the Remove field button. To add a new field, press the Add field button. In the 
appeared Add field dialog enter a name for the new field and select the field type. 
 

 
 

3.2.1. Field types. 
Type name Description Examples of use 
Text Text string. You can set the Size of 

text field up to 255 characters. 
Name, Address, Email, Note. 

Number (integer) Integer number. 
(You can set the Primary key 
option to Yes, if you want to get a 
unique auto incremented field.) 

Count, ID, Quantity. 

Floating point Floating-point number. Price, Expenses. 
Yes/No Boolean field. You can only store 

Yes or No in this field. 
Yes/No values. 

Date Date. Date. 
Memo Text string of unlimited length. Note, Memo, Address. 
Embedded file Embedded document or image file. Maps, Documents, Photos. 
 
We need the following fields for our simple Mailing List database: 

1. ID (unique Id of each record). 
2. First Name. 
3. Last Name. 
4. Email. 

 
Remove all other fields. 
 



Power Data User Guide 

© Copyright 2002 Epocware, Paragon GmbH 9

 
 
Then press the OK button to finish creation of the table. The next step is adding new records to the table. 
 

 

3.2.2. Field properties. 
Select the Field properties command from the Table menu to set special (additional) field properties. 
The Field properties dialog will appear. 
 

 
 
Select a field in the Field choice list, and then you can set a special ability for this field in the Special 
choice list. By default it’s None. You can also choose Lookup and Formula. 
 
Lookup 
The field with Lookup ability will be presented in the record as a choice list. You will be able to choose 
its value from a pre-build set of values. Go to the Lookup pane of the Field properties  dialog to define 
these values. 
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Formula 
The field with Formula ability is not entered directly, but calculated from the others record values. Go to 
the Formula pane of the Field properties dialog to define the formula. Use the Insert formula button 
for quick inserting field names. 
 

 
 
Use the Check formula button to check your formula. 
 
Example: You have Price, Amount and Total fields. Enter values only in Price and Amount fields. And 
define Total as a formula field, where the formula is Price*Amount.  
 
You can also rename fields and define default field values in the Field properties dialog. 

3.3. Adding records to a table. 
To add a record to a table, you need to open the table first: select the table and press the Open table 
button. 
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You will see the contents of the table. The new table is empty. To add a new record, press the New 
record button and enter the details of the new record. Then press the OK button. 
 

 
 
The new record was added to the table: 
 

 

3.4. Views and view options. 
There are two different ways for viewing the records of a table: 
 

1. Cards view. There are two panels in this view. The left panel (Browser) shows a list of the 
records. The right panel (Card) shows the fields of the current record. You can switch between 
these two panels by pressing the Change focus or the Tab buttons. 
 

 
Cards view. 

 
2. List view. This view presents a grid in which each record represents a row and the fields are 

shown in the columns. Multiple records can be shown simultaneously. 
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List view. 

 
By default the Cards view is used. To switch between the views select the Switch view command from 
the View menu or use the Ctrl+Q hotkey. 

3.4.1. Zoom. 
Use the Zoom keys to zoom in/out the contents of a table in the both Cards and List views. 

3.4.2. Title. 
The Title shows the names of the current database and table. It also contains the number of records in the 
table. 
 

 
No title. 

 
You can show/hide the title by selecting the Show title command from the View menu. 

3.4.3. Full screen. 
In the List and Cards view you can select the Full screen command from the View menu to enlarge the 
working screen area. 
 



Power Data User Guide 

© Copyright 2002 Epocware, Paragon GmbH 13

 
 

3.4.4. Column width. 
In the List view you can change the width of the columns by selecting the Columns width command 
from the View menu or use the Ctrl+W hotkey. Make the width smaller to see more columns on the 
screen. 
 

 
Small column width. 

 
Make the width larger to see the entire contents of the columns. Or select the Fit to screen option to fit all 
the columns into the screen. 

3.4.5. Browser fields in Cards view. 
In the Cards view you can configure what fields to show in the Browser window. Select the Browser 
fields command from the View menu. For example, to show LastName + FirstName: 
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3.5. Editing records. 
To edit a record in the Cards view, select the record in the Browser and press the Change focus or the 
Tab buttons to move the focus to the Card. Edit the record in the Card, then press the Change focus 
button again to move back to the Browser. 
 

 
 

To edit a record in the List view, select the record and press the Open record button. 

3.6. Sorting records. 
To sort the records in the table select the Sort by command from the Find&Sort menu or use the Ctrl+S 
hotkey. In the Sort by dialog select the field to sort by and press the OK button. 
 

 
 
The records will be sorted by the selected field: 
 

 
 
To change the sort order from ascending to descending, select the Sort order command from the 
Find&Sort menu. 
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Note: The * character in the header (the first row) indicates the field that’s used for sorting. 
 
Note: You can break the sort order by modifying existing or adding new records. To restore it select the 
Refresh command from the View menu or use the Ctrl+R hotkey. 

3.6.1. Indexes. 
The Indexes is another way for sorting the records in a table. When you use the common Sorting, 
modifying or inserting new records can break the sort order. Furthermore, using the common Sorting in 
the big tables can few minutes every time when you apply sorting or open the table. 
 
The Indexes provide the way to have always up-to-date (permanent) and fast sorting. 
 
To create an index in a table, select the Indexes command from the Find&Sort menu or use the Ctrl+I 
hotkey. In the appeared Indexes dialog you will see the list of existing indexes (there is no one yet). 
 

 
 
Then press the New button to create a new index. The New index dialog will appear. 
 

 
 
Here you can select up to three fields to create index by. In the Options tab you can set how many 
characters of a text field are used for indexing. 
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Then press the Create button and Power Data will create the desired index and apply it: 
 

 
 
Later you can apply the index by selecting it in the Indexes dialog 
 

 
 
or directly from the Tables view: 
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3.7. Finding. 
To find a record in the table that contains some text, select the Find command from the Find&Sort menu 
or use the Ctrl+F hotkey. In the appeared Find dialog enter the text you want to search for and press the 
OK button. 
 

 
 
Then the cursor (selection) will move to the next record that contains the desired text. 
 

 
 
Note: To find the next record that contains this text, select the Find again command from the Find&Sort 
menu or use the Ctrl+G hotkey. 
 
You can fine the search by specifying the following options: 
 
Options Descriptions 
Where Select the field where to search the text. 
Direction Set the direction of the search (Up or Down). 
Case sensitive If perform a case sensitive search or not. 
Match Select the Substring to search for a sub string. 

Select the Exact to search for an exact coincidence.  
Select the Pattern to search using a pattern (use the ? character instead of any 
character; use the * character instead of any sequence of characters). 

3.7.1. Fast find. 
The Fast find is intended for finding in huge tables (e.g. 100 000 records). The Fast find works 10-20 
times faster. To perform the Fast find select the Fast find command from the Find&Sort menu. 
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The Fast find searches a table and finds all the records that begin with entered text in the specified field. 
To perform a search the Fast find creates an index by the field. This can take few minutes at the first time, 
but the next time you use the Fast find, the already created index will be used. 
 
Then the Fast find shows the found results: 
 

 
 

Press the Esc button to return to the original table view. 

3.7.2. Bookmarks. 
You can use bookmarks when navigating through a table. Select the Set bookmark command from the 
Record menu (or press the Ctrl+B hotkey) to set a bookmark. Then select the Go to bookmark 
command from the Record menu (or press the Ctrl+Shift+B hotkey) to return to the marked record. 
 
You can set multiple bookmarks. The bookmarks create a queue. When you select the Go to bookmark 
command, you will return to the last bookmark that you set. 

3.8. Filtering records. 
A Filter is a way to retrieve data (records) from a table by using criteria you specify. You can create 
filters using one of the following wizards: 

3.8.1. Find filter. 
The Find filter retrieves the records that contain some text. To apply the Find filter select the Find filter 
command from the Filters menu or use the Crtl+Shift+F hotkey. In the appeared Find filter dialog enter 
the text that filtered records must contain and press the OK button. 
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Only the records that contain the desired text will be shown in the filtered view. 
 

 
 
Note: To remove the filter, press the Esc button. 
 
You can fine the filter by specifying the following options: 
 
Options Descriptions 
Where Select the field where to search the text. 
Case sensitive If perform a case sensitive search or not. 
Match Select the Substring to search for a sub string. 

Select the Exact to search for an exact coincidence.  
Select the Pattern to search using a pattern (use the ? character instead of any 
character; use the * character instead of any sequence of characters). 

3.8.2. Advanced filter. 
You can create really complex filters with the Advanced filter. To apply the Advanced filter select the 
Advanced filter command from the Filters menu or use the Crtl+Shift+A hotkey. In the appeared 
Advanced filter dialog compose the criteria and press the OK button. 
 
Example: To retrieve the records where the First Name begins with the J letter, use the following filter: 
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The result is: 
 

 
 
You can set several conditions combined with the logical OR and AND operations. For example: 
 

 
 
The result contains the records where the First Name begins with the J letter and the Last Name does not 
equal Smith: 
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3.8.3. Show/hide fields. 
Use the Show/hide fields filter to hide some fields (columns) and/or change the order of columns. To 
access the filter select the Show/fide fields command from the Filters menu. 
 

 
 
The result is: 
 

 

3.8.4. SQL filter. 
If you are familiar with the SQL language, you can use it for creating filters. Select the SQL filter 
command from the Filters menu. Enter an SQL select query and press the OK button. 
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SQL syntax 
 
 Description Examples 
SELECT  A list of field names to show in the filtered 

view or the * character (means all fields). 
FirstName, EmailAddress 
* 

WHERE  One or more conditions combined with the 
logical OR, AND, NOT operations. Allowed 
operations are =, >, <, >=, <=, <, >, like. String 
must be enclosed in single quote characters. 

ID=0 
FirstName<>’James’ 
FirstName like ‘J*’ AND ID>0 

ORDER BY  A list of field names to sort by. Use the ASC 
(default) and DESC keywords to specify the 
sort order. 

FirstName 
FirstName DESC, EmailAddress ASC 

3.8.5 Template filters. 
Using the Template filters you can create filters where the conditions are not bound to concrete values, 
but the values are asked when you apply the filter. 
 
Select the Create filter>Template filter command from the Filters menu. In the appeared Template 
filter dialog define the condition, but replace the values with variable names enclosed into % characters. 
 

 
 
Then press the OK button and enter the name for the created template. 
 
Now select the created template filter from the Filters>Saved menu. 
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Power Data will ask you for the variable value: 
 

 
 
Enter it and press the OK button. The filter will applied with the value that you entered: 
 

 

3.8.6 Managing filters. 
You can save a filter/sorting to apply it next time when you open a table. To save the current filter select 
the Save current filter command from the Filters menu. 
 
To access the saved filters select the Saved filters item from the Filters menu. In the appeared menu pane 
select a filter that you want to apply. 
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You can also access filters from the database view. Select a table and press the Right arrow key to 
expand it. When the table is expanded, the items for all saved filters are shown. Select the desired filter 
and press the Open button. The table will be opened and the selected filter will be applied.  
 

 

3.8.7 Color filters. 
The Color filters do not filter the records, that answer some condition, but highlight them with specified 
text or background color. 
 
Select the Color filters command from the Filters menu. In the appeared Color filters dialog press the 
New button to create a new filter. The New color filter dialog will appear. 
 

 
 
Enter a name for the new color filter. Select the text and background colors. Then press the Condition 
button and define the condition.  
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Press the OK button to close the Condition dialog. Then press the OK button to close the New color 
filter dialog.  
 

 
 
Now press the Close button and you will see the result: 
 

 

3.9. Reports. 
Power Data gives you a powerful tool for analyzing your data – Reports. Using reports you can calculate 
summary of any field in a table. You can find minimum, maximum, average values of any field. You can 
group all records in the table by any field and calculate the count of records in each group. 

3.9.1. Group amount report. 
Open a table you want to create a report from. Then select the Group amount command from the 
Reports menu. The Group amount dialog will appear: 
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Here you can select a field to group the records by (optional). Set the Count records option to Yes, if you 
want to count the records. 
 
You can also set up to three fields to calculate in each group. In the Field line select the desired filed and 
in the Calculate line select the operation (Sum, Min, Max, or Avg). 
 
Example: 
We have a table that contains orders. Each order (record) has the following fields: Product, User Name, 
Address, Email, Country, and Copies. 
 
We want to create a report to see how many copies of each product were purchased. In the Create report 
dialog we should select Product in the Group by line. And select Copies and Sum in the Field and 
Calculate lines (see the screenshot above). 
 
The result is the report that has three columns: Product, Copies (Sum) and Count. The Copies column 
contains the number of copies for each product. The Count column contains the number of orders for each 
product (one order might contain several copies). 
 

 
 
You can sort the report by selecting the Sort by command from the Find&Sort menu. 
 
You can export the record to a file by selecting the Import/Export> Merge in command from the Files 
menu. 

3.9.2. Total amount report. 
Open a table you want to create a report from. Then select the Total amount command from the Reports 
menu. The Total amount dialog will appear. Select the fields to show in the report and press OK. All the 
number fields will be summarized and the total amount will be placed in the last record. 
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3.9.3. Managing reports. 
You can save a report to apply it next time when you open a table. To save the current report select the 
Save report command from the Reports menu. 
 
To access the saved reports select the Saved reports item from the Reports menu. In the appeared menu 
pane select a report that you want to apply. 
 

 
 
You can also access reports from the database view. Select a table and press the Right arrow key to 
expand it. When the table is expanded, the items for all saved reports and filters are shown. Select the 
desired report and press the Open button. The table will be opened and the selected report will be applied.  

3.10. Importing data. 
Power Data provides functions to import records within a table. The external file formats supported by 
Power Data are CSV (Comma delimited plain text) files, DBF (dBase) files and Power Date files. 
 
To import data into a new table, select the Import/Export>Import new table command from the File 
menu. Select the file to be imported in the Import table dialog. 
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Enter a name for the new table: 
 

 
 
If you import data from a CSV file, then the Csv format options dialog appears, where you can specify 
appropriate CSV options for your file. Use the Preview button to examine the contents of the file. 
 

 
 
Note: Set the Field names in first row option to Yes if the first row in the CSV file contains the field 
names. 
 
Note: If your CSV file is not in the Western European (Windows) encoding, then press the Encoding 
button and choose the correct encoding. 
 
In the next Choose fields to import dialog you can select which fields you want to import. By default all 
the fields are imported. To change this select a field and press the Import/Do not import button. 
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To change name and/or type of an imported field, select the field and press the Change button. Then 
press the OK button to finish the importing. 

3.10.1. Merge in. 
To import data into an existing table, either highlight the table name or open the table. Select the 
Import/Export> Merge in command from the Files menu. The subsequent process is very similar to 
importing a new table. The difference is that instead of the Choose fields to import dialog, the Set fields 
mapping dialog will be presented, where you need to establish the mapping between the source and 
target fields. 
 

 

3.11. Exporting data. 
To export records from a table, open the table first. Then select the Import/Export>Export table as 
command from the Files menu and select the export format. 
 

 
 
Select a file name for the export file in the Export table to dialog. 
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Then the Csv format options dialog appears if you selected the CSV export format. See the previous 
topic for more information about the CSV options. 
 
After this the table will be exported. 
 
Note: If you have a filter applied to the table, then only the filtered records will be exported. 

3.12. Compacting a database. 
When you delete records and tables from a database, the space occupied by this data is not automatically 
freed. You need to do it manually from time to time by selecting the More>Compact database 
command from the File menu. 

3.13. Compressing a database. 
When you use a database only for viewing, you can choose to compress it. The compressed database will 
be about two times smaller, but you will not be able to add/modify its contents. This option is useful for 
references and dictionaries. To compress a database select the More>Compress database command 
from the File menu. 
 
To decompress a database select the More>Decompress database command from the File menu. 

3.14. Preferences. 
To open the Preferences dialog choose the Preferences command from the Tools menu. 
 

 
 
You can set the following options in the Preferences dialog: 

• The Open last database option determines whether Power Data opens the last used database at 
startup or not. 

• The Open last table option determines whether Power Data opens the last used table when you 
open a database or not. 
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• The Apply last filter/sorting/index option determines whether Power Data applies the last used 
filter/sorting/index when you open a table or not. 

• The Show tips at startup option determines whether Power Data shows the tips at startup. 
• The Compact mode option switches between Auto/Manual/With confirmation modes of 

compacting databases. 

3.14.1. View preferences. 
To open the View preferences dialog choose the View preferences command from the Tools menu. 
 

 
 
You can set the following options in the View preferences dialog: 

• The Font option determines what font is used to show your data. 
• The Browser width option sets the width of the Browser window in the Cards view. 
• The Show field names option determines whether Power Data shows field names in the Cards 

view. 
• The Show grid lines option determines whether Power Data shows the grid lines in the List view. 

 
The Columns tab allows you to specify the custom width and alignment for all the table columns in the 
List view: 
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